[Jalview-discuss] Alignment server access is missing under "Web Services" in Jalview 2.7

Jim Procter jprocter at compbio.dundee.ac.uk
Fri Sep 30 15:16:15 BST 2011


Found the problem ... in your console output, there are the following 
warnings:

 >Jalview Desktop 2.7
 >Build Date: 28 September 2011
 >Java version: 1.5.0_19
 > ppc Mac OS X 10.4.11
.. and then:
Exception in thread "Thread-6" java.lang.UnsupportedClassVersionError: 
Bad version number in .class file
     at java.lang.ClassLoader.defineClass1(Native Method)
     at java.lang.ClassLoader.defineClass(ClassLoader.java:620)

Here lies the problem. Your machine does not have Java 1.6 (because 
apple never released a PPC build of java 1.6), and Jalview 2.7 as 
released this week isn't compatible with Java 1.5.

It's possible I can rebuild Jalview so it will run under java 1.5, but 
the ideal solution would be for you to move to a newer machine that 
supports Java 1.6 (nearly all intel based macs can run java 1.6), since 
I suspect that java 1.5 compatibility will be even more difficult to 
maintain in future Jalview releases.

Sorry about this !
Jim.

ps. I'll email next week if we've managed to build Jalview 2.7 for java 
1.5. Unfortunately, I can't get around to this any sooner.



More information about the Jalview-discuss mailing list