[Jalview-discuss] Web start failing if caching turned off

Jim Procter jprocter at compbio.dundee.ac.uk
Tue Jan 10 15:47:47 GMT 2012


Hi there, Fred.

On 10/01/2012 15:28, Fred Ludlow wrote:
> Hi,
>
> I'm trying to run the webstart version of Jalview under windows from 
> the main link on the website 
> (http://www.jalview.org/webstart/jalview.jnlp).
>
> If I run with a fairly standard Java setup (Java 1.6.0_29 on XP) 
> Jalview seems to work fine, but if I run with caching turned off (Java 
> control panel -> General tab -> temporary internet files -> settings) 
> I get the following error:
>
> com.sun.deploy.net.JARSigningException: Found unsigned entry in 
> resource: http://www.jalview.org/webstart/castor-1.1-cycle-xml.jar
wonderful. from what I can see, the version on the site is *definitely* 
signed with the same certificate as the rest of Jalview's libraries. 
However, it did expire on Boxing day - which normally means you are 
issued with a warning, rather than preventing Jalview from launching...
> The simple answer would be to not turn caching off, but I'm running 
> other applications that fail for different reasons when run with 
> caching turned on...
Could you try to launch jalview again, after first clearing/uninstalling 
it from the web start cache ?  (Right click on the corresponding entry 
in the list of java web start apps that are shown when you run 'javaws 
-viewer' from the run dialog box). This should delete any old files that 
are still hanging around.
> Has anyone else encountered / solved this problem? I saw there was a 
> related issue in the FAQ section of the website, but that's to do with 
> having an up to date jnlp file (I'm using the current one from the 
> website, so I don't think that's the issue here).
Web start is a remarkably fragile mechanism - if anyone can tell us 
what's going on here I'd also appreciate it!!

Jim.



More information about the Jalview-discuss mailing list