[Jalview-discuss] Web start failing if caching turned off

jprocter at compbio.dundee.ac.uk jprocter at compbio.dundee.ac.uk
Wed Jan 11 11:01:33 GMT 2012

Hi Fred. This looks entirely plausible, and imho should be logged as a bug in webstart. I'll see what I can do...

J. B. Procter Jalview/enfin Barton group

-----Original Message-----
From: Fred Ludlow <fred.ludlow at gmail.com>
To: Jim Procter <jprocter at compbio.dundee.ac.uk>
Cc: jalview-discuss at jalview.org
Sent: Wed, 11 Jan 2012 9:39
Subject: Re: [Jalview-discuss] Web start failing if caching turned off

HI Jim,

On 10 January 2012 15:47, Jim Procter <jprocter at compbio.dundee.ac.uk> wrote:

> Could you try to launch jalview again, after first clearing/uninstalling
> it from the web start cache ?  (Right click on the corresponding entry in
> the list of java web start apps that are shown when you run 'javaws
> -viewer' from the run dialog box). This should delete any old files that
> are still hanging around.

I've cleared the cache, unfortunately this doesn't fix it, but see below

>  Has anyone else encountered / solved this problem? I saw there was a
>> related issue in the FAQ section of the website, but that's to do with
>> having an up to date jnlp file (I'm using the current one from the website,
>> so I don't think that's the issue here).
> Web start is a remarkably fragile mechanism - if anyone can tell us what's
> going on here I'd also appreciate it!!

I tried it on another machine, with Java 1.6.0_15 / Win XP, and it worked
both with and  without caching enabled. I then upgraded that machine to the
latest version (1.6.0_30) and I have the same behaviour (works with caching
turned on, fails with it turned off).

The best I could come up with on the web is this link:


The suggestion is that if any referenced jar file's manifest file contains
an entry for a directory it will cause problems when caching is turned off.
castor-1.1-cycle-xml.jar does have entries like:

Name: org/exolab/castor
Sealed: false

So maybe removing those from the manifest file would fix it, though I'm not
sure if that would also break something...

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.compbio.dundee.ac.uk/pipermail/jalview-discuss/attachments/20120111/e2f5f00c/attachment-0001.html 

More information about the Jalview-discuss mailing list