[Jalview-discuss] OSX 10.6.8 Jalview installation issue

Neil Rzechorzek njr48 at cam.ac.uk
Fri Mar 13 12:39:47 GMT 2015


Dear Jalview-discuss,

I'm having a problem installing Jalview on my system, OSX 10.6.8.

Java version is listed as:

java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-10M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

Using the webstart file results in complaints about needing Java 1.7

Using the standard Install Anywhere package results in the following issue:
........
System cannot find valid java to launch the application
........

Using the Install Anywhere package including Java VM results in the 
following three error messages:
...........
Fri Mar 13 11:41:16 njr48-mb.bioc.cam.ac.uk install-jalview[28919] 
<Error>: kCGErrorInvalidConnection: CGSGetCurrentCursorLocation: Invalid 
connection
Fri Mar 13 11:41:16 njr48-mb.bioc.cam.ac.uk install-jalview[28919] 
<Error>: kCGErrorFailure: Set a breakpoint @ CGErrorBreakpoint() to 
catch errors as they are logged.
Fri Mar 13 11:41:16 njr48-mb.bioc.cam.ac.uk install-jalview[28919] 
<Error>: kCGErrorInvalidConnection: CGSGetCurrentCursorLocation: Invalid 
connection
............

Followed by successful inflation of the jre.zip archive, but then 
followed by:
............
2015-03-13 11:41:23.587 java[28929:1a03] *** NSInvocation: warning: 
object 0x113b7d400 of class 'ThreadUtilities' does not implement 
methodSignatureForSelector: -- trouble ahead
2015-03-13 11:41:23.602 java[28929:1a03] *** NSInvocation: warning: 
object 0x113b7d400 of class 'ThreadUtilities' does not implement 
doesNotRecognizeSelector: -- abort
logout
...............

Am I doing something wrong here? My version of Java for my system seems 
up to date....

Many thanks for any help you can provide!

Neil


More information about the Jalview-discuss mailing list